10 Day Forecast not working

  • 2
  • Problem
  • Updated 3 weeks ago
The forecast10day call is not longer working for me. It doesn't give me the proper data anymore when fetching the info as a JSON object. The call I need to make is this:
http://api.wunderground.com/api/my_key/forecast10day/q/Australia/Glenorchy.json
but I get this object back
{
"response": { "version":"0.1", "termsofService":"http://www.wunderground.com/weather/api/d/terms.html", "features": { "forecast10day": 1 } , "results": [ { "name": "Glenorchy", "city": "Glenorchy", "state": "TSM", "country": "AU", "country_iso3166":"AU", "country_name":"Australia", "zmw": "00000.15.94970", "l": "/q/zmw:00000.15.94970" } , { "name": "Glenorchy", "city": "Glenorchy", "state": "VCT", "country": "AU", "country_iso3166":"AU", "country_name":"Australia", "zmw": "00000.17.94836", "l": "/q/zmw:00000.17.94836" } ] } }
I need this to work. I even tried the call with other cities (major ones) but they also don't return proper data.
Photo of Collin McCabe

Collin McCabe

  • 1 Post
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 2
Photo of Erik Johansson

Erik Johansson

  • 1 Post
  • 0 Reply Likes
I have the same problem with Stockholm, Sweden. 
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes
This happens when there are 2 coordinates for a city.  Use the "l" value for /q/zmw:00000.15.94970 to be the city instead and you'll go right to it.
Photo of Joe Krivan

Joe Krivan

  • 1 Post
  • 0 Reply Likes
10 day forecast will not come up for any station I put in. Anyone help?
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 126 Posts
  • 15 Reply Likes
What are you trying, Joe?  I don't know of any issues.

Victoria Gardner
victoria.gardner@ibm.com