10 Day Forecast not working

  • 8
  • Problem
  • Updated 16 hours ago
The forecast10day call is not longer working for me. It doesn't give me the proper data anymore when fetching the info as a JSON object. The call I need to make is this:
http://api.wunderground.com/api/my_key/forecast10day/q/Australia/Glenorchy.json
but I get this object back
{
"response": { "version":"0.1", "termsofService":"http://www.wunderground.com/weather/api/d/terms.html", "features": { "forecast10day": 1 } , "results": [ { "name": "Glenorchy", "city": "Glenorchy", "state": "TSM", "country": "AU", "country_iso3166":"AU", "country_name":"Australia", "zmw": "00000.15.94970", "l": "/q/zmw:00000.15.94970" } , { "name": "Glenorchy", "city": "Glenorchy", "state": "VCT", "country": "AU", "country_iso3166":"AU", "country_name":"Australia", "zmw": "00000.17.94836", "l": "/q/zmw:00000.17.94836" } ] } }
I need this to work. I even tried the call with other cities (major ones) but they also don't return proper data.
Photo of Collin McCabe

Collin McCabe

  • 1 Post
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 8
Photo of Erik Johansson

Erik Johansson

  • 1 Post
  • 0 Reply Likes
I have the same problem with Stockholm, Sweden. 
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes
This happens when there are 2 coordinates for a city.  Use the "l" value for /q/zmw:00000.15.94970 to be the city instead and you'll go right to it.
Photo of Joe Krivan

Joe Krivan

  • 1 Post
  • 0 Reply Likes
10 day forecast will not come up for any station I put in. Anyone help?
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
What are you trying, Joe?  I don't know of any issues.

Victoria Gardner
victoria.gardner@ibm.com
Photo of Larry Bryant

Larry Bryant

  • 1 Post
  • 0 Reply Likes
I havn't been able to get this either for a couple of weeks.???????
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
Larry, could you please email me directly with details?  What platform (computer, mobile, brand, browser) are you using, and what PWS are you trying to call?

Victoria Gardner
victoria.gardner@ibm.com
Photo of Sam

Sam

  • 1 Post
  • 0 Reply Likes
I am having the same problem on a Dell laptop running chrome.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
Can someone please email me an example?  I have no idea what you're seeing/not seeing that's the problem.  Screen shots, please!

Victoria
victoria.gardner@ibm.com
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
And just so you don't think I'm crazy, are you talking about this?  Or something else?
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
I also need the locale/PWS you're looking at the forecast for.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
And if it's an API call that's not working for you, can you provide me with the call?  Either extract the key and post here, or email it straight to me.

--Victoria
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
The image of the 10-day forecast above is like what I'm having trouble with the advertisement loads on the left, but the graphics on the 10-day forecast don't load. It just drawa the background and goe away for minutes (hours?)
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
Linux laptop, dell inspiron 15; Ubuntu 16.04 LTS; Firefox 65.0 (64 bit); https://www.wunderground.com/forecast/us/nh/greenville/42.73%2C-71.78?cm_ven=localwx_10day Opened the local weather and clicked on the 10-day tab. Monday ca. 8:45 am EST Feb 11, 2019


Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
onmozfullscreenerror is deprecated. sca.17.4.95.js:33:3442
WebRTC interfaces with the “moz” prefix (mozRTCPeerConnection, mozRTCSessionDescription, mozRTCIceCandidate) have been deprecated. sca.17.4.95.js:33:4653
TypeError: The ReadableStream reader was released. sca.17.4.95.js:33:12663
a: 0ms sca.17.4.95.js:32:8001
onmozfullscreenerror is deprecated. sca.17.4.95.js:33:3442
WebRTC interfaces with the “moz” prefix (mozRTCPeerConnection, mozRTCSessionDescription, mozRTCIceCandidate) have been deprecated. sca.17.4.95.js:33:4653
TypeError: The ReadableStream reader was released. sca.17.4.95.js:33:12663
This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for further details and to join the discussion on related tools and features! 42.73,-71.78
Permission denied to access property "document" on cross-origin object
ca:6:61
An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing
container.html:8
Use of Mutation Events is deprecated. Use MutationObserver instead. ca:249:61
getName on googletag.Slot is deprecated and will be removed. Use getAdUnitPath instead. pubads_impl_301.js:1:85327
TypeError: "e.slot.j is undefined"

    value https://www.wunderground.com/static/newrelic-google-publisher-tag.v2.0.6.min.js:7 Zl https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 Wl https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 Mm https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 E https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 Mm https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 visibilityChanged https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 tc https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 k https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 ib https://securepubads.g.doubleclick.net/gpt/pubads_impl_301.js?21063140:1 Xb https://securepubads.g.doubleclick.net/gpt/pubads_impl_rendering_301.js?21063140:1 og https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Z https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Db https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Ug https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Ua https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Sg https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Qd https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Nd https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 Qd https://www.googletagservices.com/activeview/js/current/osd.js?cb=/r20100101:1 invokeTask https://www.wunderground.com/bundles/polyfills.a4427223207f6ffd6222.js:1 runTask https://www.wunderground.com/bundles/polyfills.a4427223207f6ffd6222.js:1 invoke https://www.wunderground.com/bundles/polyfills.a4427223207f6ffd6222.js:1 nrWrapper https://www.wunderground.com/forecast/us/nh/greenville/42.73,-71.78?cm_ven=localwx_10day:43

pubads_impl_301.js:1:76179
getName on googletag.Slot is deprecated and will be removed. Use getAdUnitPath instead. pubads_impl_301.js:1:85327
TypeError: "e.slot.j is undefined"



Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
FABULOUS, Jim -- can you hit me with these screen shots on my email?  --Victoria

victoria.gardner@ibm.com
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
About 9:25 am, it started working again.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
Naturally -- as soon as I report the problem!
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
Firefox, Ubuntu 18.04, laptop Dell inspiron 15, The preceding screens are from related problem, not 10-day forecast not working, but next day detailed forecast always goes to San Francisco. Below are console screenshots. I have tried tis at several times of day over a period of several days. navigated to weather for "Greenville NH USA 03048" clicked on "hourly" tab, got "today's detailed weather. Clicked on forward arrrow for next day's detailed weather,., Got San Francisco main page.
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
From today's detailed forecast page, click on 10-day tab. Body of the 10-day forecast is blank.
Photo of Tim Roche

Tim Roche, Official Rep

  • 333 Posts
  • 36 Reply Likes
If you have any ad blocking software try turning it off, we don't intentionally break things if ad blockers are on, but sometimes it messes up the page
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
I'm not conscious of running any ad-blocking software. (possibly Firefox has made it a standard feature. ) Firefox is set to block pop-up windows and deceptive content, but not ads per se. I sometimes see advertisements and sometimes don't.
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
This morning, when I navigate to what should be thje main page of wunderground.com, I see the San Francisso page, and there are already errors in the Web console.
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
I I then tyoe in a location "Greenville NH 03048" which usually gets me local weather, I see:
Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
https://www.wunderground.com/weather/us/nh/greenville/42.73%2C-71.78 is the saved URL, I have been using to start wunderground with local settings. It brings up a page that looks like this:

Photo of Jim Giddings

Jim Giddings

  • 13 Posts
  • 0 Reply Likes
The errors seem to be present from the start, no matter how I navigate to wunderground. Since these errors began, I don't remember seeing advertisements, but as I point out above, I am not aware of having any ad-blocking software running.,
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
Thanks for the reports, Jim!  I've passed them to the web people!

Have you tried this in Chrome?  

--Victoria
(Edited)
Photo of tiller gilman

tiller gilman

  • 1 Post
  • 0 Reply Likes
i have been using Wunderground for a long time.Lately the 10 day extended forecast will not come up,on Firefox or Chrome.Oh the ads come up great tho ....
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
The engineers are working on this.  You've seen the message, I'm guessing, about the profiles being worked on.  The ad-free status is in the profile.  They're working just as fast as they can.  

Victoria Gardner
victoria.gardner@ibm.com
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Okay, for a report, here is the ideal amount of information:
  1. Platform/browser (Mac, Dell, etc, Chrome, IE, Safari, etc).  If it's a smart phone, be sure to tell me which model.  If you're running an older OS, please mention it.
  2. Screen shot with URL visible if possible.  If you can, also show the browser console, aka javascript console.  This should also include the location for the weather.
  3. Date/time and location of the machine (phone, computer) making the call (no assumptions about looking only at local weather from me!).
  4. The path you took to the page.  Where did you start in the WU sphere?  How did you get to 10-day from there?
Email it to me, Victoria Gardner, victoria.gardner@ibm.com.

I'm a user of the web site too, I've seen this (highly intermittent) error as well.  I know this is a lot of information, but an intermittent error is hard to catch/reproduce, and the more data we have the more likely it is to get fixed.  The techs haven't been able to reproduce it, but if we can catch it, hopefully we can provide the info they need to fix it.

Thank you, and good luck!  

Victoria Gardner
victoria.gardner@ibm.com
Photo of Maura

Maura

  • 3 Posts
  • 0 Reply Likes

Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Yes!  I was having trouble this morning, too, and sent a whole series of screen shots to support.  What platform/browser are you using, Maura?

Victoria Gardner
victoria.gardner@ibm.com
Photo of Maura

Maura

  • 3 Posts
  • 0 Reply Likes
Win 7 Pro N 64 bit on a Core i5 CPU running at 3.4 Ghz with 16GB Ram

Photo of Maura

Maura

  • 3 Posts
  • 0 Reply Likes
Chrome build is 72.0.3626.81   This started reliably happening when searching for some, but not all areas about a week or two ago. 

Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Thanks, Maura!  
Photo of Steven S

Steven S

  • 1 Post
  • 0 Reply Likes
issue started last week.  The links to change weather station also does not work.   I am using chrome
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Steven, please email me.  I need to know more specifics if I'm to report this to the programmers.

Also, please keep in mind there is a mechanism for reporting errors on the Weather Underground web site.  At the moment, I'm the exact same person who will help you there.  But it makes the work flow a lot easier to handle.  WU web site feedback and support:  https://feedback.weather.com/?b_id=17298

--Victoria
victoria.gardner@ibm.com
(Edited)
Photo of David McNutt

David McNutt

  • 1 Post
  • 0 Reply Likes
Hourly 10 day & map not working for Datil NM also can not change stations I'm guess y'all finally screwed it up good,,,So can you give it back to whomever.... you know back in the good old days when we could Track storms and other things
(Edited)
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 554 Posts
  • 77 Reply Likes
So I just pulled up the weather for Datil, NM, and the 10-day.  I'm not seeing issues, but that doesn't mean they don't exist.  Can you tell me:

A) What browser/app, device/computer you're having the problem with?
B) What the problem actually is?  Is the page not plotting correctly, 404 error, what exactly?  
C) Are you logged in to wundergound.com when the error occurs?
D) What path are you taking to get to the page(s) that you're having trouble with?
E) Have you tried clearing cache and/or reloading the page (the counter-clockwise arrow usually found to the left of the navigation bar in most browsers) or rebooting the app on a mobile device?
F) What is the frequency of the error?  All the time, intermittent?

Thank you!

Victoria Gardner
victoria.gardner@ibm.com
Photo of Kyle DePietro

Kyle DePietro

  • 1 Post
  • 0 Reply Likes
Yes, I have not been able to get the 10 day forecast for 04578 either for several weeks. All the local stations have also gone and it automatically routes me to the Augusta weather station which is 30 miles away from the coast. I am a farmer and have come very used to checking weather underground to plan out my days but will be changing weather sites as it no longer works.

Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 559 Posts
  • 78 Reply Likes
Kyle, would you email me directly with more information?  Wunderground seems not to be able to work out the zip code.  But I want to make sure I address your 10-day issue, too.

--Victoria Gardner
victoria.gardner@ibm.com
Photo of Tim Roche

Tim Roche, Official Rep

  • 334 Posts
  • 36 Reply Likes
please try this URL https://www.wunderground.com/weather/us/me/wiscasset  I'm not sure why you are getting a station so far away
Photo of Timothy Jaxon

Timothy Jaxon

  • 1 Post
  • 0 Reply Likes
I've had the same issue for over a month now - strangely only on my computer at home.  My laptop is showing the 10-day forecast with no issues.
Photo of BluBtrfly

BluBtrfly

  • 1 Post
  • 0 Reply Likes
For several weeks the 10 day forecast has not been working for me.  I just checked on IE and it appear that it is working.  However, on Chrome it is just blank for every city I look up.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
So if you're a user who logs in, this is one thing to try, especially if the only problem you're having is 10-day displays:  Log in to wunderground.com.  Click on the gear wheel in the upper right and change the units to Celsius.  Go somewhere on the site.  Change back to Fahrenheit.  For most users, this fixes the 10-day display.

However, with Chrome's recent update, all manner of things have gotten wildly flaky.  For instance, I cannot, for love or money, log in to this Forum with Chrome now.  I know on my own computer, this is almost entirely a Chrome issue -- other browsers don't behave the same way.  Needless to say, I'm reporting the errors, but I would expect that those triaging the errors will put single-browser issues below all-browser issues. 

--Victoria

Photo of Sheridan Joyce

Sheridan Joyce

  • 2 Posts
  • 0 Reply Likes
Been a couple months since my 10 day or calendar has worked in chrome, deleted all temp files associated with the site with no effect. everything works perfectly in internet explorer. except calendar, that's tossing me out to a blank white screen right now for some reason now. 

in chrome all the stuff below additional conditions doesn't load on the main weather screen. This is on win 7 desktop
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Sheridan, do you log in to Weather Underground?  If so, try this hack:
Log in to wunderground.com.  Click on the gear wheel in the upper right and change the units to Celsius.  Go somewhere on the site.  Change back to Fahrenheit.

Now look at the 10-day page.  It should display correctly.

If not, drop me an email. 

--Victoria
victoria.gardner@ibm.com

Photo of Sheridan Joyce

Sheridan Joyce

  • 2 Posts
  • 0 Reply Likes
I don't normally log in, However when I click the gear icon nothing happens, chrome acts as if the gear is just a picture vs a link
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 566 Posts
  • 81 Reply Likes
Drop me an email.  I would like to get some screen shots of any errors before trying to reset things.

--Victoria
Photo of John Harold

John Harold

  • 1 Post
  • 0 Reply Likes
Just saying..... Running Chrome on Windows 7, the 10 day forecast no longer works, BUT if I use Explorer, everything works fine. On my Galaxy 8S smartphone, Wunderground.com works sometimes, other times nothing.