10 day forecast response is not populated

  • 3
  • Problem
  • Updated 10 months ago
My site requests a 10 day forecast every hour and I use simpleforecast data to display a 5 day forecsat.  Lately I have noticed the response for 10 day forecast has no data in simple forecast so I end up with no forecast displayed on my site. One or two requests (hours) later the data is returned.  Just wondering why this is?  wuapi response used to be reliable.  I now have to add code to detect this error condition and display the previous hours forecast rather than no forecast at all for an hour or two. 

www.newfoundlakeweather.com
Photo of Paul

Paul

  • 13 Posts
  • 1 Reply Like

Posted 10 months ago

  • 3
Photo of derekj212

derekj212

  • 3 Posts
  • 1 Reply Like
We're seeing this also. Pretty crazy to think you may be paying for requests that aren't even returning a forecast.
Photo of derekj212

derekj212

  • 3 Posts
  • 1 Reply Like
Paul, what account type/tier are you using?
Photo of Paul

Paul

  • 13 Posts
  • 1 Reply Like
cumulus
Photo of Ameen

Ameen

  • 7 Posts
  • 0 Reply Likes
Photo of Eric Avila

Eric Avila

  • 8 Posts
  • 4 Reply Likes
I had some issues with hourly_forecast object (the one that comes next 26h) from the api, randomly it does not comes and this broke my app.. I request it again and it comes...
Photo of MattMcGuire

MattMcGuire

  • 5 Posts
  • 0 Reply Likes
We too have a Cumulus account and are missing out on many forecasts only to have them populated by querying again later, but then other locations which previously had all forecast days are missing them.  It's been happening for about a week now.

Is there any timeline for a solution to this yet?
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
We are looking into this right now, and our tech support email got some similar examples of it not working correctly. 
Photo of derekj212

derekj212

  • 3 Posts
  • 1 Reply Like
Any updates here?
Photo of Paul

Paul

  • 13 Posts
  • 1 Reply Like
From my point of view the frequency of problem responses (i.e. fewer than 10 days of data returned in a forecast10day json request) is less than it was the first two weeks of January.  Each time I detect a problem I send the json response to tech support e-mail.  My most recent detected (and reported ) problem was Wed 01/24/18 05:16:02 PM est