API not working

  • 17
  • Problem
  • Updated 2 weeks ago
There is a webserver problem with our data in cloud hosting provider.  They shut down all of the instances and they are not coming back up correctly.  We have all hands on deck and are working through the problems as quickly as possible.  Please bear with us as we work to fix this. 
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes

Posted 11 months ago

  • 17
Photo of Ganny

Ganny

  • 5 Posts
  • 0 Reply Likes
Hi, more than 50% of my api calls are bad. The forecast shows 0 Degrees!!! The people watching my Homepage thinking thats are a bad Site. The fails are falling back to me! The problem exists more than of 2 years. People fix the problems, or i went to other!
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
What URL are you hitting?  If the problem has existed for 2 years, it is unrelated to the current issue
Photo of Ganny

Ganny

  • 5 Posts
  • 0 Reply Likes
and my neighbours Station...
Photo of Ganny

Ganny

  • 5 Posts
  • 0 Reply Likes
And my other neighbours Station.
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
The temperature isn't 0, that's an empty degrees symbol.  Not the best display.  It means that the low temperature forecast for the day has passed.  This forum is for the API though.  I'll share your feedback with the app development team. 
Photo of Ganny

Ganny

  • 5 Posts
  • 0 Reply Likes
No, i have an php script with api calls on my homepage. On the script shows the empty symbol as 0 degrees. The Question is why shows the empty symbol? I have send my data every 5 minutes.
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
Brendan, Thanks for current update. Both PWS reporting and access to recent historical data, along with cams, and the other bells and whistles, are a bit of a rollercoaster ride, as you are aware. Thanks for efforts and updates. Montanaphil
Photo of David Reynolds

David Reynolds

  • 2 Posts
  • 0 Reply Likes
Is this problem related to the map issue? No maps have updated since Jan 3. except for the local radars.
Photo of Alex

Alex

  • 1 Post
  • 1 Reply Like
Good evening, all weather stations netatmo around me, including my disappeared from the WU map is related to this problem?
Photo of Cameron Ryan

Cameron Ryan

  • 1 Post
  • 0 Reply Likes

We have reports from multiple European customers of WU API not returning PWS stations when doing a geolookup. As an example, the following query has the problem:

https://api.wunderground.com/api/ced984e24ae2492b/geolookup/q/52.6299,13.3274.json

If I look on your Wundermap then there are lots of PWS in this area...

(Edited)
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
What is the latest with this problem? When should we expect to see these problems corrected. PWS’s continually cutting out, no daily summary, counter not showing visits above 1, what gives?
(Edited)
Photo of Babis Kalpak

Babis Kalpak

  • 3 Posts
  • 0 Reply Likes
here with one photo the problems is more than usually ,at 95% of pws return data from metar airports, i understand the wu because sometimes happend when use dynamic data servers.

from the other side i cannot understand why some problems still after 1 week, i hope programmers resolve this problem and at the future wu resolve and some other problems with api because is not very stable data 1 year now.

but we love wu because gives so manys apis to us to work with this apis. thanks wu and now is the time to need be more patiense all of us
Photo of logray

logray

  • 7 Posts
  • 0 Reply Likes
Queries are not providing PWS data even if we specify pws:1.  This started about a day ago.  Please advise.
Photo of ZdH

ZdH

  • 1 Post
  • 0 Reply Likes
Looks like everything works! Congratulations. 
Photo of John M Hartlove

John M Hartlove

  • 14 Posts
  • 5 Reply Likes
Not everything; you still can’t save the status.
Photo of kristy chambers

kristy chambers

  • 1 Post
  • 0 Reply Likes
everything is not working!! What is going on???
Photo of John M Hartlove

John M Hartlove

  • 14 Posts
  • 5 Reply Likes
Brendan, how about some sort of an update?
(Edited)
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
I agree that an official update of system status is in order. KMTPLAIN4 and associated weathercam continue to have problems at WU end. Cam was dropped after only 8 hours of stagnant image, all the while successfully uploading current images. Station page says I'm not reporting after 6 minutes, when I clearly am. Still no way to update status, and visit counter still stuck at 1. On the upside, there are now 200% more PWS options for my Montana location, and WU has introduced a new feature on the PWS station pages ( DISQUS ) I remain patient as always, Montanaphil  
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes
Our team knows.  They have been spending days and nights working on things, but it turns into a whack-a-mole game.  The changes made to servers to prevent the Meltdown vulnerability decreased their efficiency so they don't scale the same.  We are trying to balance the load with the right number of servers.  This includes ingesting the data, storing the sata, and replicating the data across the servers.  We know its broken and have not stopped working on it.   I'm sorry for the trouble this has been causing.   
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
Thank You !! 
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
Thank you! We appreciate your response and efforts. What will be done to prevent this in the future?

Thank You for the continued efforts!
John
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
New problem, no web cam posting. They all stopped last night about 11pm eastern
(Edited)
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
Cams are down again. Started dropping off around 11am today. FTP test on several cams of mine not getting into the servers. Looking at wonder map, most cams in the same situation. Someone PLEASE fix these servers. Oh, I didn’t get the “I’m sorry email”. Been a paying member since 2008.
(Edited)
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
Yes John, it seems the explanation/apology e-mail was premature. Weather data at 15 minute intervals I can live with for awhile. Cam images, especially DOT highway cams here in Montana, have to be current to be effective. Image update lag currently up to 6 hours now, including my own PWS. Been a rough ride for all the last 10 days. 
Photo of Hans Huijsman

Hans Huijsman

  • 1 Post
  • 0 Reply Likes
Any idea how long this will take ?
Photo of SD Maley

SD Maley

  • 7 Posts
  • 0 Reply Likes
Some PWS owners apparently got emails yesterday, re: https://www.wxforum.net/index.php?topic=33628.0
Photo of conligwx

conligwx

  • 5 Posts
  • 0 Reply Likes
I too have noticed webcam images have stopped being displayed. they are however being accepted in ftp uploads.  they are just failing to be processed by WU
(Edited)
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
The servers occasionally accept the image, yes. However none are posting. There are a few scattered around the country that are squeaking by. Unsatisfactory either way.
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
As of Sunday morning,1-14-18, Cams are being dropped and inactivated by WU, at exactly 24 hours stale. This has always been standard policy, and is one of the few things that you can count on to work at WU currently. This is regardless of FTP uploads reporting success or failure. I still remain optimistic that WU can get a handle on this. I am using the Disqus feature at bottom of station page to post status and current image. See KMTPLAIN4. 
Photo of Kenneth Rieck

Kenneth Rieck

  • 7 Posts
  • 2 Reply Likes
All the same problems here (KORREDMO58), but my Cam exceeded 24 hours by at least 10 minutes!  and it's gone now.

Really I just had a question, where do you plug in the photo on your 'about PWS' link?
Photo of MontanaPhil

MontanaPhil

  • 10 Posts
  • 3 Reply Likes
Kenneth, the photo was posted late 2016 by uploading using the now discontinued Wunderphotos feature at WeatherUnderground. I am not aware of a workaround for that currently, but someone on this forum may know for sure. Regards, Montanaphil
Photo of JC Hale

JC Hale

  • 1 Post
  • 0 Reply Likes
5/27/2018
Mine is still not working. I loved this app when it worked.
Unable to load complete page for several weeks now.  HELP!!
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
Cannot change date on Weather Underground PWS site
Photo of Leo Schulz

Leo Schulz

  • 5 Posts
  • 0 Reply Likes
My Weather Underground site only works some of the time.  It never gets better.  Does anyone know if they are going out of this service?  My Davis Weather link seems to work good and it was just released?  https://www.weatherlink.com/bulletin/eeb7e036-fc88-4a65-9515-47596c324e94
 KORNEWPO10        Newport, Or.
Photo of John M Hartlove

John M Hartlove

  • 16 Posts
  • 5 Reply Likes
Now they’ve totally removed status so we cannot do anything. Is that considered fixed ?
Photo of Leo Schulz

Leo Schulz

  • 5 Posts
  • 0 Reply Likes
Do you know of another wx site that we can post to?
Photo of James Anding

James Anding

  • 59 Posts
  • 48 Reply Likes
You can post your PWS data here:
https://www.pwsweather.com

Then use Aeris Weather for your API.
Far superior to the evil WU.
https://www.aerisweather.com/support/docs/api/getting-started/

WU has already screwed all its loyal users and PWS owners.
I see no reason that this won't continue.


Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 71 Posts
  • 9 Reply Likes
Hi Leo and James.

I understand that these changes can be difficult but I want to assure you that Personal Weather Station (PWS) contributors will continue to have complete access to their own data as well as a limited range of additional data, such as short-term forecast, through the Weather Underground API as well as through the Wunderground web site. If you have a PWS currently reporting to us, your access for that data is, and will be, free.

There are a variety of other open access services.  You are free to make your own choices in that regard.  Every site is going to go through changes, some of which may seem reasonable and some of which won't.  If you're already connected to Weather Underground, you're already part of the community.  I've personally been on WU for decades, and I know I'm not turning away anytime soon.

I'm pretty sure no one at WU is evil.  Just real people working really hard to do the best that they can. 

Victoria Gardner
victoria.gardner@ibm.com
Photo of James Anding

James Anding

  • 59 Posts
  • 48 Reply Likes

WU has ignored bugs, ignored request for information, for years now.
I used your service and reported bugs, I get no response. I have watched others report bugs and issues and actually beg for help only to receive silence. THAT IS EVIL.

You have totally ignored these users and knowingly held back important information
for a very long time about stopping the service and changing the API.

You ack like this big change was a total surprise that just suddenly happened and you're now giving us
information? Please, everyone is not as stupid as you think. 

No respectable company, NONE, announces termination with that short of notice and NO plan, NO detailed API reference to the changes, NO pricing information, THAT IS EVIL.

Your company knows that the average PWS owner doesn't use an API, they just upload data to you so you can make money with it. If you lose every user that writes apps you don't care, Why? Because there are hundreds of thousands of unknowing users that this won't have an impact on and they will just blindly keep sending you data.

Too bad that they don't know how sorry you are. Too bad they're not in the loop of information. Too bad because if they were they would stop sending you their data.

Eventually you will get what you deserve. Users will eventually wake up and find a decent company to do business with, I just hope it's sooner than later.






Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 71 Posts
  • 9 Reply Likes
I'm sorry you feel that way, James.  I hope you'll have a pleasant day.

Victoria Gardner
victoria.gardner@ibm.com
Photo of Marcus Pullan

Marcus Pullan

  • 1 Post
  • 0 Reply Likes
Started failing to load any data 2 days ago. Reinstalled app, will not connect to any stations. Same with my wife’s. Both on iPhones if that matters
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 168 Posts
  • 23 Reply Likes
Okay, if you're having problems with Weather Underground's mobile app, the best place to report it is somewhere related to that.  This forum is for the API.  

That said "failing to load" doesn't tell me much.  Failing to load what?  Where?  On what sort of device?  "Connect to stations" meaning PWSs you control?

I'll need more information in order to report an issue.

Victoria Gardner
victoria.gardner@ibm.com