API-key not found after registration

  • 21
  • Problem
  • Updated 2 years ago
Today I signed up for a new api-key. Registration worked all fine (I can login now) but I cannot find a key anywhere on the site. An email with the requested key is also not received.
So after logging in, where do I find my api-key? Thank you in advance, Raymond.
Photo of EastNed

EastNed

  • 3 Posts
  • 1 Reply Like

Posted 5 years ago

  • 21
Photo of JohnSully

JohnSully

  • 2 Posts
  • 0 Reply Likes
I just signed up today and have the same problem. Once one has signed up for a developer key, how is one supposed to discover what it is?
Photo of EastNed

EastNed

  • 3 Posts
  • 1 Reply Like
John, hi.

Had email-contact with someone from Wunderground. It seems that, when singing up (by filling in the form) you only create a new account. After that you again have to choose the desired plan (after login in of course) and then you do get fowarded to a page with a key.

Good luck,

Raymond.
(from the Netherlands).
Photo of mush4brains

mush4brains

  • 1 Post
  • 0 Reply Likes
Hi,
I suppose this problem still exists. However I followed Raymond's suggestion and I now have an API key.
Thanks,Chuck
Photo of VanEijkDevelopment

VanEijkDevelopment

  • 1 Post
  • 0 Reply Likes
Still the same now. But thanks Raymond for supplying your answer
Photo of Tim Roche

Tim Roche, Official Rep

  • 259 Posts
  • 19 Reply Likes
Hi, 

I checked, and you do have a key.  You can see it here
http://www.wunderground.com/weather/api/
you must be signed in to the wunderground site to see this
Photo of EastNed

EastNed

  • 3 Posts
  • 1 Reply Like
To anybody reading my first post. See my comment on John's post for the solution.
Photo of JohnSully

JohnSully

  • 2 Posts
  • 0 Reply Likes
It turned out that the page (Profile Information) which had a way to register your application and which returned an application key was not for the WU API but rather for get satisfaction (I assume). Once I went through the purchase procedure again I got a valid key.

The sign up procedure here is gruesome, but once navigated the API seems to be easy enough to use.
Photo of jbarko

jbarko

  • 2 Posts
  • 0 Reply Likes
even trying several times after logging in and choosing a different option each time, I am not receiving a key anywhere. Upon signing up, i'm returned to the API home page :( Am I missing something?
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
There was a bug on the sign up page. Try again, and if it doesn't work, get in touch with tech support: http://help.wunderground.com/
Photo of Tim Osborn

Tim Osborn

  • 1 Post
  • 0 Reply Likes
hmm.. i've been around the loop a few times now... got an account, verified, etc.
I don't even see the Weather API navigation with the 'key settings' item until I click 'Forums'.

'Key settings' takes me to the create new or regenerate key page (with plans below), but a new key is not created, cant' regenerate, and the 'Purchase Plan buttons don't work with (any plan) + developer selected :(

OSX, Chrome
Photo of WunderWilliam

WunderWilliam

  • 267 Posts
  • 17 Reply Likes
Could you write to help@wunderground.com with the email that you used to register an account?

We may need account details, so it's best to resolve this outside of a public forum.

Thanks!
Photo of jbw976

jbw976

  • 2 Posts
  • 0 Reply Likes
I just ran into this issue as well. I didn't have a previous wunderground account. I went through the entire API key registration process and created an account inline as the last step of filling out all the forms.

Once logged in, the API key was nowhere to be seen. Going through the entire API key registration process again was successful the second time and now my API key shows up OK.
Photo of WunderWilliam

WunderWilliam

  • 267 Posts
  • 17 Reply Likes
If you sign up for an account at the same time as a key, sometimes the system will make the account but won’t generate the key.

It's an annoying bug, and we'll fix it.
Photo of Snapprewards

Snapprewards

  • 1 Post
  • 0 Reply Likes
Not fixed yet - what a POS
Photo of steve63

steve63

  • 3 Posts
  • 0 Reply Likes
Agreed -- it's ridiculous that it's so hard to get the key.

You should be ashamed of yourselves...
Photo of Tim Roche

Tim Roche, Official Rep

  • 259 Posts
  • 19 Reply Likes
Hi steve, 

I'm not aware of any bugs in the signup process at this time.  Could you shoot me an e-mail and help describe the steps so we can ensure that the process runs smoothly?  

thanks
tim
Photo of steve63

steve63

  • 3 Posts
  • 0 Reply Likes
I don't know your email address, so I'll put it here:

- I "purchased" a dev key and the site seemed to accept my inputs.
- But, I didn't receive any emails and my key was never shown to me. And, I couldn't figure out how to get the key on the site.
- So, I created an account and clicked the subsequent email's activation link, which seemed to succeed
- Again, I didn't receive any emails and my key is not displayed anywhere on the site; at least -- like the users above -- not that I can find...

FWIW, I usually have no issues navigating cumbersome API registration processes (e.g., Google's and Salesforce's).
Photo of Gianni Manfrini

Gianni Manfrini

  • 1 Post
  • 0 Reply Likes
I have the same problem. I registered for an account but did not receive the free API KEY
Photo of pigscantfly

pigscantfly

  • 1 Post
  • 0 Reply Likes
Same problem here
Photo of Rambo7201

Rambo7201

  • 3 Posts
  • 0 Reply Likes
I have also problems.
Photo of Tim Roche

Tim Roche, Official Rep

  • 268 Posts
  • 19 Reply Likes
Hi All,

I believe this is a UI bug, as there are actually 2 registration processes to go through.  Please click the verification link from your e-mail and read the red print on that page carefully.  You will need to login, then continue on to sign up for an API key
Photo of Rambo7201

Rambo7201

  • 3 Posts
  • 0 Reply Likes
I deleted this mail.

What must i do now?
Photo of tmg1961

tmg1961

  • 1 Post
  • 0 Reply Likes
where can i find my key? Not showing anywere.
Photo of Waregem

Waregem

  • 1 Post
  • 0 Reply Likes
Same problem (Belgium)
Photo of Rambo7201

Rambo7201

  • 3 Posts
  • 0 Reply Likes
You must buy a key.

Than you have it.
You have not to pay for it.
Photo of plauge

plauge

  • 4 Posts
  • 0 Reply Likes
Is this a joke?

I've done all and there is still no key?

Where can I find it?
Photo of plauge

plauge

  • 4 Posts
  • 0 Reply Likes
I do not get it. On this page I can recreate a key - but I still get no key???

http://www.wunderground.com/weather/a...
Photo of plauge

plauge

  • 4 Posts
  • 0 Reply Likes
I give up! Bye...
Photo of jbw976

jbw976

  • 2 Posts
  • 0 Reply Likes
man, some people on this thread are super complainers. if there's a bug in software, be constructive and help get it fixed instead of acting like an entitled brat.

no /u/plauge, the registration experience is not a "joke", it just has a bug for some users.

real helpful, /u/Snapprewards by calling it a POS. that comment will surely get the bug fixed.

a lot of software users that run into a bug act like the developers are incompetent morons...do you complaining users always write perfect bug free code that works on all scenarios/platforms/users with zero issues in production? if so, please send me your resume...otherwise STFU

From my response earlier in this thread, this could help folks out, basically register for an API key a second time and hopefully that works:
"I just ran into this issue as well. I didn't have a previous wunderground account. I went through the entire API key registration process and created an account inline as the last step of filling out all the forms.

Once logged in, the API key was nowhere to be seen. Going through the entire API key registration process again was successful the second time and now my API key shows up OK."
Photo of plauge

plauge

  • 4 Posts
  • 0 Reply Likes
This bug is "one year old". How hard can it be to fix it? :-)
Photo of steve63

steve63

  • 3 Posts
  • 0 Reply Likes
I can only assume that we, the affected, are so small a minority of the developers who register. And, Wund's maintenance team is so busy with other work (go figure?) that they can't be bothered to fix the bug for us.

Either that, or they're incompetent -- this isn't rocket science, after all. I know because for decades I've been designing, building, maintaining and *supporting* software systems that are orders of magnitude more complex than register/keygen/auth.

In case you missed it, the only reply in this thread from an "Official Rep" was 25 days ago (after I wrote they should be ashamed of themselves). He asked me to PM him, but didn't give me his email address. Fail #2 (ignoring us was Fail #1). But, their forum software either doesn't support PM, or is configured to not do so. Fail #3. So, I replied to his question the next day. But, there has been no further response from any "Official Rep" -- 25 days and counting! Fail #4.

But, along come the troglodytes, because Wund doesn't moderate this forum. Fail #5.

I gave up on Wund, since I'm satisfied with the many other weather providers. I was still following the thread, out of curiosity to see if Wund ever decided to fix the issue. But, I'm tired of counting their failures. So, good bye and good luck!