API not responding to queries, returns "missing key: you must supply a key" error

  • 7
  • Problem
  • Updated 4 years ago
Valid key but getting no response and "you must supply a key" error. Also can't login to API website. I suspect it's not just me.
Photo of Tcmoran

Tcmoran

  • 5 Posts
  • 1 Reply Like
  • frustrated

Posted 4 years ago

  • 7
Photo of Tibor Voros

Tibor Voros

  • 5 Posts
  • 0 Reply Likes
Same here! I started a separate tread at the same time.
I noticed this about an hour ago, I really hope they will fix it as soon as possible.
Photo of EIZSOFT

EIZSOFT

  • 17 Posts
  • 0 Reply Likes
Same here!!!!!!!!!!!!!
Photo of Tcmoran

Tcmoran

  • 5 Posts
  • 1 Reply Like
Also sometimes gives:

Service Unavailable - Zero size object

The server is temporarily unable to service your request. Please try again later.
Reference #15.b86f1160.1395121368.d118fb0
Photo of Graeme K

Graeme K

  • 1 Post
  • 0 Reply Likes
Noted same with API key error on requests (even their examples no longer work).

Whole WU site is slow, or simply times out in the api section.
Photo of Tcmoran

Tcmoran

  • 5 Posts
  • 1 Reply Like
Working again for me. It would be nice to have an explanation for the outage to know whether it's likely to happen again.
Photo of arclance

arclance

  • 29 Posts
  • 0 Reply Likes
The ssl api is down right now, so is ssl login to the main wunderground site.
It seems to have started at the same time as this.
Photo of WunderWilliam

WunderWilliam

  • 267 Posts
  • 18 Reply Likes
If the problem is still occurring, please send the exact call that you're making to support@wunderground.com

Thanks!
Photo of HurricaneTrackerNC

HurricaneTrackerNC

  • 7 Posts
  • 0 Reply Likes
This is still an issue. I have submitted my exact call to support but have heard nothing back. I get the same error as above, "Service Unavailable - Zero Size Object." In my case, it seems related to the "yesterday" call option in the API.

I hope this issue is resolved soon (and permanently)!
Photo of John

John

  • 2 Posts
  • 0 Reply Likes
+1

API is broken - it only happens for history queries on personal weather stations.