AutoIP not found?

  • 4
  • Problem
  • Updated 3 years ago
When I try to use the autoip service, I get an error saying no cities matched my search query. Am I missing something?
Photo of Relsqui

Relsqui

  • 3 Posts
  • 0 Reply Likes
  • disappointed

Posted 6 years ago

  • 4
Photo of Relsqui

Relsqui

  • 3 Posts
  • 0 Reply Likes
More detail. Here's my python code, only slightly modified from the example:

import urllib2
import json
from pprint import pprint

f = urllib2.urlopen('http://api.wunderground.com/api/MYKEY...)
json_string = f.read()
parsed_json = json.loads(json_string)
pprint(parsed_json)
f.close()

Inserting my actual API key and running it yields:

{u'response': {u'error': {u'description': u'No cities match your search query',
u'type': u'querynotfound'},
u'features': {u'astronomy': 1, u'conditions': 1},
u'termsofService': u'http://www.wunderground.com/weather/a...,
u'version': u'0.1'}}

I get the same error if I use ?geo_ip to inquire after a specific IP.
Photo of Relsqui

Relsqui

  • 3 Posts
  • 0 Reply Likes
Bah, I missed the /IA/ in the example URL. Took that out and of course it worked. My bad! Feel free to delete this. :)
Photo of Sri Krishna

Sri Krishna

  • 2 Posts
  • 0 Reply Likes
I am doing the same process, and am a developer working from my work-place with the API autoip feature. URL :
api.wunderground.com/api/API_KEY/geolookup/q/autoip.xml
I am getting an error type : query not found.
with description : No cities match your search query.
I need help resolving this problem asap. please help.
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
What happens when you hit this?
http://www.wunderground.com/cgi-bin/f...
Photo of TommyBB

TommyBB

  • 4 Posts
  • 0 Reply Likes
I'm having this issue as well, and I get an error message when clicking the link. See below...
Photo of TommyBB

TommyBB

  • 4 Posts
  • 0 Reply Likes
I seem to be experiencing the same thing.

Using this url: "http://api.wunderground.com/api/API_K..."

I get "No cities match your search query". Any idea why?
Photo of TommyBB

TommyBB

  • 4 Posts
  • 0 Reply Likes
Also, this link: http://www.wunderground.com/cgi-bin/f...

Leads to this error message:

"There has been an error!
City Not Found

We're sorry, but the page you have requested was not found.

The search for "autoip" did not return results."
Photo of TommyBB

TommyBB

  • 4 Posts
  • 0 Reply Likes
Some progress. Or clues, at least.

Visiting http://api.wunderground.com/api/API_K...
from my desktop computer gets me the "no match" error, but when checking it from my phone I at least get a response, even though it's geographically way off. (I'd expect "Stockholm, Sweden", but got "Hamra", which makes no sense to me).

By the way: when visiting www.wunderground.com the service successfully pins my location to Stockholm... so I don't get why it's not working for me. I'd guess it uses the same autoIP functionality?
Photo of Kapilw

Kapilw

  • 1 Post
  • 0 Reply Likes
"error": {
"type": "querynotfound"
,"description": "No cities match your search query"
}

I am getting this error for autoip service

How can I get current location?
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
With the timeout issue we're dealing with, there was a period of time during the night the "autoip" search did not work. It was restored this morning though, and "autoip" should be working correctly again.
Photo of Ashish Bansal

Ashish Bansal

  • 1 Post
  • 0 Reply Likes
Hi,

I am trying to use autoip... but it is not working still...can you confirm the url which i am using is right?

http://api.wunderground.com/api/Api_key/conditions/lang:EN/q/autoip.json
Photo of afelicioni

afelicioni

  • 227 Posts
  • 43 Reply Likes
Hi Ashish,
the URL pattern you're using looks right.

May I also suggest you to query for a particular IP? Have a try for example IP 8.8.8.8 with the pattern /q/autoip.json?geo_ip=8.8.8.8 and analyze if conditions for Mountain View, California are returned.