FTP Authentication Fails on webcam upload

  • 4
  • Problem
  • Updated 2 months ago
I added a new camera and FTP authentication fails, even though I'm using exactly the same script as I use for my first camera (honomuCAM3). I've tried deleting and re-adding the webcam and am now up to honomuCAM6 with no success, trying log in with the provided password and, just to test, my account password. Nothing works. In addition to the Python script I use to upload honomuCAM3, I also tried gftp and even command line FTP with no success:

ftp> open webcam.wunderground.com
Connected to webcam.wunderground.com.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 400 of 10000 allowed.
220-Local time is now 00:40. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 60 seconds of inactivity.
Name (webcam.wunderground.com:dl): honomuCAM6
331 User honomuCAM6 OK. Password required
Password:  
530 Login authentication failed
ftp: Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> close
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.
ftp>

Do I need to set up a separate Wunderground account to add a second camera? 

TIA for any suggestions

      -- Doug
     weather.honomu.net

Photo of Doug Lung

Doug Lung

  • 2 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 4
Photo of Colin Lord

Colin Lord

  • 3 Posts
  • 0 Reply Likes
I'm also having this issue. It doesn't accept my user/pass combo whether it's through Python, PHP, or a direct FTP connection from the command line.
Photo of Roland

Roland

  • 7 Posts
  • 0 Reply Likes
Exactly the same problem et NO answer from the support.
Photo of Frank

Frank

  • 2 Posts
  • 0 Reply Likes
Same here , saying User name or password incorrect? Have emailed support numerous times, and still no response ?
(Edited)
Photo of Frank

Frank

  • 2 Posts
  • 0 Reply Likes
I have copied and pasted my user name and password directly from my weather underground, but still no go. I have set a webcam for another person with exactly same camera model and works perfectly. Help.
Photo of Colin Lord

Colin Lord

  • 3 Posts
  • 0 Reply Likes
It's interesting that some users can upload and a group of us cannot. I can't imagine this is related to the camera model since that's just a text field that gets displayed next to the camera.

Another thing I tried was switching to a URL where they fetch the camera image from me. That also isn't working. Looking at my requests, nobody ever tries to fetch an image regardless of the time I select for each image update.

Either way. Radio silence from support.
Photo of Roland

Roland

  • 7 Posts
  • 0 Reply Likes
The problem is first that the support is overload and don't solved any trouble on the FTP server. For example I have delete the first defined camera ( this was working for months) after it come offline. This old ID and password is still working with FTP software. I just see a .ftpquota empty file.  I create a new camera , but with this ID and correct password it's impossible to connect via FTP and of course it stay offline. 

This is the proof that the support does nothing to solve all those problems. My analyse is that the FTP server are over quota, so all new device are not anymore activated. Gratis support are in this case f... support. 

I don't believe that in a near future the will do some things for us. 


Photo of chuck k

chuck k

  • 1 Post
  • 0 Reply Likes
Also not able to ftp up pictures for months now. There is no customer support Wunderground has bin going down hill fast. About a year ago they wiped out my station Id and then told me there was no way for me to get it back. I had been using the same ID from the very beginning I guess 15 years my id was also my skywarn spotter id . I guess all good things get F  k up sooner or later. Very BAD
Photo of Jay Blizman

Jay Blizman

  • 3 Posts
  • 3 Reply Likes
With this type of support or lack of support makes me question the integrity of WU.  If I didn't like weather so much, I would stop watching the WU segments on the Weather Channel.
Photo of BlacknWhite

BlacknWhite

  • 2 Posts
  • 0 Reply Likes
Yep, same problem here, a whole month later.

Hello support?

Anybody?
Photo of Tim Roche

Tim Roche, Official Rep

  • 356 Posts
  • 53 Reply Likes
try now with your upload key
Photo of Doug Lung

Doug Lung

  • 2 Posts
  • 0 Reply Likes
Hi Tim --

I'd removed the upload code from my Python program so took a while to test it but it seems to be working fine now. The upload is showing successful!

Thanks very much for fixing this. You now have a new camera in Honomu!

        -- Doug

Photo of Colin Lord

Colin Lord

  • 3 Posts
  • 0 Reply Likes
Things seem to be working again for me as well. You have another new camera...this one in Nashville, Tennessee!