Getting error on autoip request

  • 1
  • Problem
  • Updated 4 years ago
No cities match your search query

http://api.wunderground.com/api/%KEY%...=

have problem currently on one IP.
Photo of infobooster

infobooster

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of infobooster

infobooster

  • 5 Posts
  • 0 Reply Likes
Just notice that the problems also occurs on other locations in the same city.

FYI: this URL is also not working: http://www.wunderground.com/cgi-bin/f...
http://www.wunderground.com/cgi-bin/f...
Photo of Tim Roche

Tim Roche, Official Rep

  • 317 Posts
  • 28 Reply Likes
Don't use the geo_ip parameter, that's for passing in an IP
http://api.wunderground.com/api/%KEY%/conditions/forecast/lang:NL/q/autoip.xml
should work
Photo of infobooster

infobooster

  • 5 Posts
  • 0 Reply Likes
using autoip is not an option. We submit the request is from our server, not the client. Server is resolving client ip and using it in the request. As far as I can understand from the documentation geo_ip parameter is the only way to push the ip-address in the request.
Photo of Tim Roche

Tim Roche, Official Rep

  • 317 Posts
  • 28 Reply Likes
correct,

the format should look like this
/q/autoip.xml?geo_ip=

it looks like you were leaving off the ip
Photo of infobooster

infobooster

  • 5 Posts
  • 0 Reply Likes
I did not in my script of course :-). I don't want to put ip-addresses from my customers on the forum. Can you see them in my account in the logging, or can I send you some examples by email or PM?
Photo of Tim Roche

Tim Roche, Official Rep

  • 317 Posts
  • 28 Reply Likes
sure send them to tim.roche@weather.com  Also check them in the maxmind geoip tool
https://www.maxmind.com/en/geoip_demo