Intermittent "keynotfound" error

  • 4
  • Problem
  • Updated 2 years ago
I am making a call once every 10 minutes to pull current conditions at my location. Every so often I get the following error:

[error] => Array    (
        [type] => keynotfound
        [description] => this key does not exist
    )

There doesn't seem to be any pattern to when I get the error.
Photo of Jakob Knigga

Jakob Knigga

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 4
Photo of Mike Beyer

Mike Beyer

  • 1 Post
  • 0 Reply Likes
I'm seeing this as well, both success and error requests return 200 http status codes, which is definitely suprising.  The headers that you get back though are slightly different.  I've included a paste below of the headers.  Also I'm seeing this aprox 33% of the time.

http://pastebin.com/zH0yuAVK
(Edited)
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes
There's an issue happening right now with some intermittent connections issues internally that are making the results you're seeing.  We are fixing it now.  
Photo of Jakob Knigga

Jakob Knigga

  • 2 Posts
  • 0 Reply Likes
How long has this been happening? I have been seeing these errors for a little over a week now. Does that sound about right for the issue you know about?
Photo of Andre Keshmeshian

Andre Keshmeshian

  • 1 Post
  • 0 Reply Likes
We've been finding this issue for many months; as early as June 2016. Do you have an ETA when this will be resolved? We have generated a new key and that has not helped resolve the issue.
Photo of Asier Santamaría

Asier Santamaría

  • 15 Posts
  • 1 Reply Like
we have the same problem
3 months later, still you haven't resolved the problem?
we are with a Stratus Shower Plan