IPTIMELAPSE reports it can't get Wunderground data

  • 2
  • Problem
  • Updated 4 weeks ago
It reports back "Station not available or invalid station ID"  But, this has been working for eight years!  The station is KNHTHORN2 which you can see is working fine. https://www.wunderground.com/dashboard/pws/KNHTHORN2

I understand that Wunderground gets its data from PWS but my upload to there is working fine too http://www.pwsweather.com/obs/PWSTHORN2.html

Anybody have an idea why it suddenly stopped working?

TIA

Bob 
Photo of Bob Hatcher

Bob Hatcher

  • 4 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 2
Photo of DebbieDo

DebbieDo

  • 2 Posts
  • 0 Reply Likes

We're having the very same issue after it's been working for years.  Our station is KMOHOLT6 .  Any news yet?
Photo of Bob Hatcher

Bob Hatcher

  • 4 Posts
  • 0 Reply Likes
Yes, WU took down the free API and now you have to buy a key.  I updated my IPTIMELAPSE to the latest version and it can get my PWS info directly.  If you buy a WU key it can get that too.

My suggestion is to use PWS rather than WU and upgrade your software to the latest version (it's $40 and the software is much better.)
Photo of Paul Hutch

Paul Hutch

  • 20 Posts
  • 7 Reply Likes
If you have a weather station that uploads to WU they give you a free API key.  Go to the "API Keys" tab of the member settings to get a free key.
Photo of Bob Hatcher

Bob Hatcher

  • 4 Posts
  • 0 Reply Likes
Thanks for the info Paul.  I got it and it works.