Issue trying to upload custom sensors readings

  • 1
  • Question
  • Updated 2 years ago
  • (Edited)
1)  I am trying to upload my pool temperature to weather underground so that I can access it via api in other applications.  In the wiki it says that temp2f is available but when searching the web I can't find anyone to get this to work.

2)  I am having problem upding my account via URL.  I have my account updating via vws without problem (Yes, I did turn that off while playing with this)

example:  this url does not update uv

http://rtupdate.wunderground.com/weatherstation/updateweatherstation.php?ID=KNYGRAND4&PASSWORD=xxxxx&dateutc=now&uv=78.2&softwaretype=RaspberryPi&action=updateraw&realtime=1&rtfreq=2.5

I do get a "success" but I can't see the value when I open my station via url.  I've tried other parms as well.
Photo of Adam Morgan

Adam Morgan

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Adam Morgan

Adam Morgan

  • 3 Posts
  • 0 Reply Likes
I realized this morning that the POST works if I use a real date/time other than "now" even though the wiki says that is supports "now"
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 123 Reply Likes
Extra variables like that can be uploaded, but aren't necessarily in the output on the API.  I'll send you an email about the issues you're seeing. 
Photo of nightshark

nightshark

  • 5 Posts
  • 0 Reply Likes
I am having trouble with this. It worked fine for over a year. Please see my other post.
Photo of Adam Morgan

Adam Morgan

  • 3 Posts
  • 0 Reply Likes
I know that the wunderground dev team is working on a new api.  In the interim I started using adafruit's free simple storage for sending/retrieving the temp from non-weather sensors.  
Photo of nightshark

nightshark

  • 5 Posts
  • 0 Reply Likes
My issue was digits after the decimal point in the dew point. It stopped accepting more than 2. I stopped uploading that for the time being until I can round it off.