Old values in XML/JSON API data

  • 2
  • Problem
  • Updated 2 years ago
I am using a Smarthome system (FHEM) which I have configured to fetch API data from a PWS every 5 minutes. Since beginning of November sometimes the values are wrong. The timestamp (observation_time) and temperature is outdated from several hours till months ago. I can also reproduce this problem in my browser (both JSON and XML).
Currently with every refresh it is switching between now, today morning and October 12th 2016.

Is this a known problem?
Photo of Dennis Schaub

Dennis Schaub

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
If you hard code a PWS id into your API request, and that PWS stops reporting, you will get old data.  Make your request by city or lat/lon and you will always get the nearest active station.
Photo of Dennis Schaub

Dennis Schaub

  • 4 Posts
  • 0 Reply Likes
The PWS is still reporting. If I open the web view of the station, everything is fine with up-to-date values.
But sometimes nearly every 2nd API call is delivering data from october.

Photo of Gert Ulott

Gert Ulott

  • 31 Posts
  • 2 Reply Likes
See also problem report "
WEATHER API IS DOWN !!!!!!!!!!!!!!!!!!!!!"
scroll down.
I think we all have the same issue since the beginning of November.
Photo of Chet Rhodes

Chet Rhodes

  • 1 Post
  • 0 Reply Likes
I am seeing the same problem, occurs 2-5 times per day over the last two weeks or so
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
The stale data bug should be fixed now. 
Photo of Gert Ulott

Gert Ulott

  • 31 Posts
  • 2 Reply Likes
Sorry but nothing changed here. ihesseno7
Photo of Dennis Schaub

Dennis Schaub

  • 4 Posts
  • 0 Reply Likes
it is working for me, IHESSENB8
Photo of Dennis Schaub

Dennis Schaub

  • 4 Posts
  • 0 Reply Likes
the peaks are back
2016-11-29 11:58:02 CET
2016-11-29 15:58:02 CET
Photo of Gert Ulott

Gert Ulott

  • 31 Posts
  • 2 Reply Likes
Since Nov 28 I do not get any valid answers on the API requsts at all. Not sure whether anyone still takes care of this.
Also I still cannot find my station except by code. SINCE 5 WEEKS NOW.
I will now look for alternatives to wheather underground.