Paid membership not showing and now getting ads

  • 1
  • Problem
  • Updated 5 months ago
I have a paid ad-free membership paid up to 6/2020.  Why does my account now say free account?  Why am I getting ads when I paid to not get them?
Photo of keith.myers

keith.myers

  • 4 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 637 Posts
  • 91 Reply Likes
Hi, Keith.  I'm sorry you're having a problem with the WU web site.

There is a known issue with logins at the moment that the web team is working on.  You can try these things:

A) Clear cache and cookies on your browser.
B) Close the browser window or refresh.
C) Try logging in again.

If this doesn't work, please be patient.  I know it's annoying -- I pay for ad-free, too, and I'm not especially happy when they reappear.  But we do know and are working on it.

Victoria Gardner 
victoria.gardner@ibm.com
Photo of Chipster

Chipster

  • 2 Posts
  • 0 Reply Likes
Victoria...  On a related matter... I've been a paid member to wunderground.com for several years (for ad-free on the web page). 

For months I'd been emailing help about extending my membership that was expiring - as the link to paypal was not working at least since late December.  

That link has now been removed - but there is no link to "extend" anymore...  How do I do that now?

I the meantime - someone read my emails - and graciously gave me a brief extension.  But still did not tell me how to pay for it going forward. 

Thanks,
Chip

Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 637 Posts
  • 91 Reply Likes
Hey, Chip!

Let me see if I can find an answer.  At a wild guess, I imagine they are switching over systems and they don't want anyone caught in the transition.  

--Victoria
Photo of Chipster

Chipster

  • 2 Posts
  • 0 Reply Likes
Ok... Thanks Victoria!

_____________
Chipster