Problem loading radar maps, documentation page formatting corrupted

  • 5
  • Problem
  • Updated 1 year ago
I can load satellite maps, but not radar maps of any kind. It doesn't even return an image and I have no errors in my browser console or the api. Attempted on two separate keys and two different networks to access radar, no luck.

Also, your docs page looks like it got attacked by 1995. I can't test the satellite+radar map easily because I can't find out the syntax because the page only shows half of two examples. 

Is this just me or did I miss something?
Photo of Sam Nickolls

Sam Nickolls

  • 5 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 5
Photo of Brandon

Brandon

  • 29 Posts
  • 7 Reply Likes
I'm  also having a problem with the radar images, the URL I have configured isn't working nor are the example URLs on the Docs page.

The Doc pages seem to be fine in my case.

The Sat Images seem fine (at least the example ones from the Docs page).
Photo of Sam Nickolls

Sam Nickolls

  • 5 Posts
  • 0 Reply Likes
Exactly the situation with my radar url. Wait and see mode at this point.

My docs pages are variations upon this, but this page (the satellite command help page) is the worst. On a Mac in Chrome.

Photo of Thomas Fuchs

Thomas Fuchs

  • 41 Posts
  • 9 Reply Likes
I have the same issue too. All my animated radar GIFs are empty/broken.
Photo of Bart Nissen

Bart Nissen

  • 2 Posts
  • 0 Reply Likes
Same here, no radar image, says requested URL is invalid.
Photo of DaveL17

DaveL17

  • 9 Posts
  • 1 Reply Like
Likewise--radar and animated radar do not load.  Satellite loads.  Docs pages also malformed.

Wish I had come here first before much debugging.
Photo of Jay Allen

Jay Allen

  • 10 Posts
  • 0 Reply Likes
Noticed the same thing this morning as well.  All my scripts run as expected but the result is always empty gifs at the moment. 
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
The radar issue is being looked into.  The documentation page has a bad CSS that is cached.  If you shift+reload or load Incognito on Chrome the page should look better.
Photo of DaveL17

DaveL17

  • 9 Posts
  • 1 Reply Like
Thanks for the prompt reply and for looking into the issue.  On Safari, deleting caches and shift-reload did not seem to resolve the CSS issue.
Photo of Sam Nickolls

Sam Nickolls

  • 5 Posts
  • 0 Reply Likes
Chrome cache!!!!! My immortal enemy.
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
Radar is fixed now.  Sorry for the troubles
Photo of Brandon

Brandon

  • 29 Posts
  • 7 Reply Likes
The radar is working better than it did now, but when I animate it the last few frames look like this
Photo of DaveL17

DaveL17

  • 9 Posts
  • 1 Reply Like
I had that too at first, but now the images appear fine.
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
The bad frames just had to clear out
Photo of Thomas Fuchs

Thomas Fuchs

  • 41 Posts
  • 9 Reply Likes
Working fine again. Thanks for the fix
Photo of Sam Nickolls

Sam Nickolls

  • 5 Posts
  • 0 Reply Likes
radar is back to normal, thank you! Stupid bad frames.
Photo of DaveL17

DaveL17

  • 9 Posts
  • 1 Reply Like
It looks like the API is now reversed for 'newmaps'.  I'm getting a transparent images when newmaps=0.  Am I missing something?

http://api.wunderground.com/api/api_key/animatedradar/WUradar.gif?radunits=nm&rainsnow=1&frame=0&height=500&minlat=39.0&num=15&timelabel=1&newmaps=0&feature=1&delay=25&width=500&maxlon=-90.5&maxlat=43.0&noclutter=1&minlon=-86.5&smooth=1&timelabel.x=390&timelabel.y=20
Photo of Thomas Fuchs

Thomas Fuchs

  • 41 Posts
  • 9 Reply Likes
This works correctly for me. 0 is transparent, 1 is with map layer as background.
Photo of DaveL17

DaveL17

  • 9 Posts
  • 1 Reply Like
Either I misread the API docs (most likely) or something changed in the docs, but regardless it's working for me as the docs say it should.
(Edited)
Photo of James Anding

James Anding

  • 57 Posts
  • 47 Reply Likes
yea, you missed all the mess.