PWS Current conditions API returning old data for all stations

  • 3
  • Problem
  • Updated 3 weeks ago
The PWS Observations - Current Conditions API is returning old data. Each time I reload, it's different - anytime from 1 to 2 days old. This is happening with every PWS station. The PWS Recent History - 1 Day - Rapid History call is returning the correct data up to the current time. It's also wrong on the Weather Underground website as well. Repeatedly refresh my dashboard and look at the time it says the data was reported, it changed almost every time.
https://www.wunderground.com/dashboard/pws/KCASACRA31
Photo of Matt

Matt

  • 9 Posts
  • 3 Reply Likes

Posted 3 weeks ago

  • 3
Photo of Alex Ruiz

Alex Ruiz

  • 3 Posts
  • 0 Reply Likes
Yeah it’s happing to me as well
Photo of Jeff Hill

Jeff Hill

  • 7 Posts
  • 1 Reply Like
Confirm that I also am getting this problem as well as the Dashboard not updating the associated webcam image.
https://www.wunderground.com/dashboard/pws/IQUEENSL289

Did you raise a ticket Matt?
Photo of JBDragon

JBDragon

  • 1 Post
  • 0 Reply Likes
Yes, all the stations around me are showing outdated Info including my own weather station.  Even though my software is showing as sending the data just fine.  Shows my Data hasn't been updated for 5 hours.  Other sites around me, 7 hours to 1 day or more.   The software I use reports to a number of sites and all those are working just fine.   
Photo of Van Mildert

Van Mildert

  • 8 Posts
  • 3 Reply Likes
Same problem with my PWS and others that I refer to. They are all showing old data and when refreshed show a different update time. My PWS App is also not up to date. My weather station software is is updating as usual to WU.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 642 Posts
  • 91 Reply Likes
There is a hardware issue that is being worked on.  Conditions and recent history should be working now; longer term history will take a bit longer to cycle up.  

--Victoria
Photo of Matt

Matt

  • 9 Posts
  • 3 Reply Likes
Current PWS conditions from the API are still coming back wrong. And I'm starting to get bad reviews in the App Store for my app because of this.
(Edited)
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 642 Posts
  • 91 Reply Likes
I think we cleared the problem about a half hour ago (around noon US east coast time).  If you're still having problems, drop a station ID in here for me to check.

--Victoria
Photo of Matt

Matt

  • 9 Posts
  • 3 Reply Likes
Looks like it's back on track now.
Photo of Alex Ruiz

Alex Ruiz

  • 3 Posts
  • 0 Reply Likes
It’s up and running.. accurate data information. Thank you Victoria.
Photo of George

George

  • 19 Posts
  • 5 Reply Likes
Victoria,
Glad this hardware issue is resolved. Thank you for keeping us informed. Will we ever see the random missing days from July 2019 restored? Just about every station has different random missing days in the month of July 2019.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 642 Posts
  • 91 Reply Likes
I hope so.  

If you have an urgent need for the data, I can pull daily summaries from the other API.  Send requests through https://feedback.weather.com/customer/portal/emails/new?b_id=17298, get the words "PWS API" in there somewhere.  And/or "missing July data".  

--Victoria