Animated Radar GIF: Setting parameter newmaps=1 causes 504 error

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
As title says. When using newmaps parameter, the GIF is not generated anymore. This should be fixed ASAP.

GIF URL I tried:
http://api.wunderground.com/api/myapikey123/animatedradar/q/KY/Erlanger.gif?width=960&height=960&newmaps=1&radius=75&noclutter=1&smooth=1&timelabel=1&timelabel.x=30&timelabel.y=30 

EDIT:
It seems to work with smaller resolutions than what I use (960 x 960). But I use this resolution since 6 months and it never caused a problem until now. Is there a maximum width/height that I missed in the documentation? 

EDIT 2:
Now it's working again as usual. Still I'd like to know what's the reason for that behavior and how it could be prevented. I'd appreciate if any official could give me a short reply to this.

EDIT 3:
Now it's down again. Really need some clarification here.
Photo of Thomas Fuchs

Thomas Fuchs

  • 41 Posts
  • 9 Reply Likes

Posted 2 years ago

  • 1
Photo of Kyle Smith

Kyle Smith

  • 1 Post
  • 0 Reply Likes
When you say "is not generated anymore" is the API giving back any error code?

My "animatedradar" feeds have been returning 504 (Gateway Timeout) errors since about 1am EDT today. I tried making the radius smaller, the width and height smaller, nothing has brought it back. 1 in every 50 requests seem to go through.
Photo of Thomas Fuchs

Thomas Fuchs

  • 41 Posts
  • 9 Reply Likes
When I get 504 nothing is returned beside of the gateway timeout message. It seems to be a temporary problem, sometimes it work and sometimes not. For me it helped to reduce width and height to make it more consistant yesterday. Today morning everything seems to work as usual and I can again use the old resolution (960 x 960) so far. I will watch it closely.