Strange Response for Weather From Some PWS

  • 1
  • Problem
  • Updated 2 years ago
Recently 2 PWS stations started returning something odd for the "weather" parameter in the json response.

    ["weather"]=>
    string(22) "LANG.kLangCondOvercast"

Other strings are affected as well:
    ["observation_time"]=>
    string(60) "Last Updated on LANG.kLang.DateTime.December 15, 1:46 PM PST"
Photo of skolia

skolia

  • 17 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of skolia

skolia

  • 17 Posts
  • 0 Reply Likes
If I try to specify language on the query it fixes the LANG,kLang stuff but most of the actual observational data is now gone:

http://api.wunderground.com/api/APIKEY/conditions/lang:EN/q/pws:KWARENTO102.json
    ["local_tz_long"]=>
string(19) "America/Los_Angeles"
["local_tz_offset"]=>
string(5) "-0800"
["weather"]=>
string(13) "Partly Cloudy"
["temperature_string"]=>
string(7) " F ( C)"
["temp_f"]=>
NULL
["temp_c"]=>
NULL
["relative_humidity"]=>
string(5) "-999%"
["wind_string"]=>
string(4) "Calm"
["wind_dir"]=>
string(1) "N"
["wind_degrees"]=>
int(0)
["wind_mph"]=>
int(0)
["wind_gust_mph"]=>
int(0)
["wind_kph"]=>
int(0)
["wind_gust_kph"]=>
int(0)
["pressure_mb"]=>
string(6) "1013.4"
["pressure_in"]=>
string(5) "29.93"
["pressure_trend"]=>
string(0) ""
["dewpoint_string"]=>
string(2) "NA"
["dewpoint_f"]=>
NULL
["dewpoint_c"]=>
NULL
["heat_index_string"]=>
string(2) "NA"
["heat_index_f"]=>
string(2) "NA"
["heat_index_c"]=>
string(2) "NA"
["windchill_string"]=>
string(2) "NA"
["windchill_f"]=>
string(2) "NA"
["windchill_c"]=>
string(2) "NA"
["feelslike_string"]=>
string(7) " F ( C)"
["feelslike_f"]=>
string(0) ""
["feelslike_c"]=>
string(0) ""
["visibility_mi"]=>
string(2) "10"
["visibility_km"]=>
string(2) "16"
["solarradiation"]=>
string(2) "--"
["UV"]=>
string(1) "0"
["precip_1hr_string"]=>
string(9) " in ( mm)"
["precip_1hr_in"]=>
string(0) ""
["precip_1hr_metric"]=>
string(0) ""
["precip_today_string"]=>
string(24) "-9999.00 in (-253975 mm)"
["precip_today_in"]=>
string(8) "-9999.00"
["precip_today_metric"]=>
string(2) "--"
Photo of skolia

skolia

  • 17 Posts
  • 0 Reply Likes
And on a subsequent query, still with lang:EN, I get data again but LANG.kLang crap again.
Photo of Buadhai

Buadhai

  • 3 Posts
  • 0 Reply Likes
I get the same thing, but inconsistently. For example:

"observation_time":"Last Updated on LANG.kLang.DateTime.December 16, 5:07 AM ICT",

For station ID (not pws): IPRACHUA7

Just started yesterday (15 December).
Photo of Brendan Hayes

Brendan Hayes, Official Rep

  • 962 Posts
  • 122 Reply Likes
I see what you mean, we are looking into it.