webcam ftp failed

  • 5
  • Problem
  • Updated 2 weeks ago
Hi, I operate two wx stations each with their own webcam uploading data to WU.
Recently I installed another station which works fine but I cannot ftp the cam image to the station. I know from tests its not a wrong setting in the camera , I tried a simple ftp program and can upload a test file to cam 1 and 2 but cannot connect to cam3 . Is there a known problem with WU atm ?
Thanks.
Photo of Steve Shuff

Steve Shuff

  • 3 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 5
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 619 Posts
  • 88 Reply Likes
Not that I know of, Steve.  Can you email me the particulars so I can check into it further?  Thank you!

Victoria
Photo of Ken Burdsall

Ken Burdsall

  • 1 Post
  • 0 Reply Likes
Do I need to re-register my webcam after the changes to the server farm this week?  Right now the system says I don't have a webcam online.  ? Just a glitch while new system is in transition?
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
Ken, can you send me your info directly?  I don't want to have to guess about ids etc.

Victoria Gardner
victoria.gardner@ibm.com
Photo of keb329

keb329

  • 2 Posts
  • 1 Reply Like
I have been having authentication failure since wunderground updated their web site.  Is there an ftp problem?  I've sent several emails to their support but I get no response.  
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
Yes, there is a known problem that is in the queue to be corrected.

--Victoria
Photo of Liam Aps

Liam Aps

  • 3 Posts
  • 2 Reply Likes

I too have the same authentication problem, been going on for about one month. Is there an estimated time for a fix?
IONTARIO836
Photo of Harry Horton

Harry Horton

  • 3 Posts
  • 0 Reply Likes
Lets get the show on the road !!
Photo of Liam Aps

Liam Aps

  • 3 Posts
  • 2 Reply Likes

"If a tree falls in a forest and no one is around to hear it, does it make a sound?"
https://en.wikipedia.org/wiki/If_a_tree_falls_in_a_forest
Photo of Michael Tapley

Michael Tapley

  • 3 Posts
  • 1 Reply Like
You know, it would be really helpful if Weather Underground could post something to their website saying they have a problem. I have spent about a day trying to fix my cameras only to read this site and find the problem is at the other end!
Photo of Michael Tapley

Michael Tapley

  • 3 Posts
  • 1 Reply Like
Not quite! Although this is helpful in explaining that there are issues, I was hoping to see something on the front page of the WU site where it is easy to find, with an alert to the outage issue and an estimated timeline to a fix but perhaps this is a bit too much to ask. 
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
Yes, too much to ask.  There's a reason there's a FAQ page, and that it's on the way to sending us an email/feedback is no accident, either.  People who are just looking for their weather don't want to be bothered with things like that. 
Photo of Claude Felizardo

Claude Felizardo

  • 30 Posts
  • 6 Reply Likes
I think the problem is finding this FAQ page to begin with.  I can understand not wanting to clutter the main weather.com web page but what about adding a sticky note on the apicommunity.wunderground.com web page similar to what you have that says "End of Feb. WU API update" which I have just dismissed or "Message from the WeatherAPI community".
Photo of Liam Aps

Liam Aps

  • 3 Posts
  • 2 Reply Likes

Better yet, FIX the problem!
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
Liam, if this were just a trivial problem, it would be fixed already.  The issue is more complex than meets the average user's eye.

Claude, unfortunately this Forum software is set up with only one person able to post those site-wide announcements.  And I, for one, don't want to drag that one person away from his other work, which is also incredibly important.

--Victoria
Photo of Claude Felizardo

Claude Felizardo

  • 30 Posts
  • 6 Reply Likes
Sorry I wasn't clear.  I'm suggesting that you post a link on the apicommunity.wunderground.com page to the FAQ at feedback.weather.com.  Then hopefully developers and uploaders will be able to find the link to the FAQ quickly.

Photo of Michael Tapley

Michael Tapley

  • 3 Posts
  • 1 Reply Like
Not sure about others but reading this response to those of us that voluntarily provide our data, I find the attitude rather hostile and dismissive. I, for one, will probably be disconnecting my weather station and looking for somewhere else other than Weather Underground to appreciate my data. There may not be anywhere else but I don't see why I should support WU any more; it's just too frustrating.  It seems defensive responses here get attention whereas e-mails and other requests for help get completely ignored. 

Goodbye!
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
I am not trying to be either hostile or dismissive.  Everyone here is working just as hard as they can to get everything working. 

We will be sorry to see you go, if you must, Michael.

--Victoria
Photo of Micheal Hennessy

Micheal Hennessy

  • 1 Post
  • 0 Reply Likes
I'm having a similar problem - Can I just check that I am using the correct credentials - The 'Username' that my software uses to upload the image would be the Camera 'ID', correct? Used to upload no problem but not for a few months... Thanks, Micheal
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
This is not working right now, Michael.  No change in credentials will fix it.  I ask for your patience while we work.

--Victoria
Photo of Richard Austin

Richard Austin

  • 4 Posts
  • 0 Reply Likes

I have the same issue.
I have done extensive testing and it appears it is Weather Underground servers failing to Authenticate my account.
I have recreated the account, rebuilt the devices, tried both URL and FTP, always the same issue, Weather Underground FTP says password incorrect and URL never even tries to retrieve the image.
I verified I can upload via FTP as I have done for years by using a third party server. This server accepts the FTP image, hosts it via a URL that works but Weather Underground never retrieves it.

I reported this months ago and again today. The Case #1576201 is from today.

Is there anybody out there in WU world that can plug the server back in so we can resolve this issue......

Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
As reported a week ago, work continues on redeveloping the FTP webcams.  There will be credentialing changes, so all efforts to add a new FTP webcam right now are a waste of your time.  As soon as I see the work has been completed, I will post something here. 

We have plenty of working URL webcams, so if you're having problems with those, here's some things to check:

A)  No special characters in the URL.  This includes colons and tildes.
B)  Make sure the URL works.
C)  Make sure servers are not blocking the upload.  Some servers are finicky and think our upload is something nefarious.  Just because the URL works when you try it does NOT mean the upload is not being blocked.  This typically means having a conversation with the cam's URL's host.

--Victoria
Photo of Harry Horton

Harry Horton

  • 3 Posts
  • 0 Reply Likes
I can upload via a url with a Reolink app. However. The link does. Not end in .jpg . Suggestions?
Photo of Richard Austin

Richard Austin

  • 4 Posts
  • 0 Reply Likes
I can upload a via FTP to sirv.com, which hosts the image as a .jpg link, but WU still wont upload that image via url or ftp either.
Photo of Harry Horton

Harry Horton

  • 3 Posts
  • 0 Reply Likes
Anyone uploading via url that can tell me how to do it? As noted on the thread, don't waste time with the old ftp way.
I have lots of tools at my disposal, synology nas plus camera apps. Just don't know how to satisfy wunderground.
(Edited)
Photo of Skip Parker

Skip Parker

  • 1 Post
  • 0 Reply Likes
WU is only publising webcams that are uploaded as an IP address via FTP. Other webcam FTP uploads connect satisfactorally but are not published. No idea if or when the issue will or ever be fixed.
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 618 Posts
  • 87 Reply Likes
Hi, Skip!

It seems like only a week ago I said that the FTP issue is in the queue to be fixed.  URL webcams are more likely to be working. 

If you are having problems with either, the best place to submit the issue is through the online feedback form, available via "Contact" on the bottom of any wunderground page or directly via this link:
https://feedback.weather.com/customer/portal/emails/new?b_id=17298

I should note that here on the Forum, on my email, and via the contact form, all roads lead to me.  If you want me to hurry up and look at your entry in the contact form, give me your case number and I will look it up.  It's much more efficient for me to have all the work in the same place.


--Victoria