weewx 3.9.2 HTTP Error 404: Not Found problem

  • 1
  • Problem
  • Updated 2 months ago
I'm using weewx 3.9.2-1 (Debian package) running on Linux / Debian Buster and in recent days I'm finding that some calls to upload data to Weather Underground are failing.  The upload fails only sometimes (around 4 to 5 times per hour) and having run weewx in debug mode, this is what appears in the log:

Feb 03 11:05:16 duck weewx[14760]: restx: Wunderground-RF: Failed upload attempt 1: HTTP Error 404: Not Found
Feb 03 11:05:21 duck weewx[14760]: restx: Wunderground-RF: Failed to publish record 2020-02-03 11:05:16 GMT (1580727916): Failed upload after 1 tries
Feb 03 11:06:56 duck weewx[14760]: restx: Wunderground-RF: Failed upload attempt 1: HTTP Error 404: Not Found
Feb 03 11:07:01 duck weewx[14760]: restx: Wunderground-RF: Failed to publish record 2020-02-03 11:06:56 GMT (1580728016): Failed upload after 1 tries
Feb 03 11:11:49 duck weewx[14760]: vantage: Requesting 200 LOOP packets.
Feb 03 11:11:49 duck weewx[14760]: vantage: Gentle wake up of console successful
Feb 03 11:13:04 duck weewx[14760]: restx: Wunderground-RF: Failed upload attempt 1: HTTP Error 404: Not Found
Feb 03 11:13:09 duck weewx[14760]: restx: Wunderground-RF: Failed to publish record 2020-02-03 11:13:04 GMT (1580728384): Failed upload after 1 tries
Does anyone have any idea what might be wrong or how I could fix it?  It seems to me that this most likely to be a WU problem as it is working most of the time and the above problems only happen occasionally each hour.  My weather data is appearing on WU, but I have noted that the data is not displayed when this issue is happening.

Many thanks,

Rupert.

 
Photo of Rupert Perry

Rupert Perry

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 months ago

  • 1
Photo of Leon Shaner

Leon Shaner

  • 12 Posts
  • 0 Reply Likes
Same error for me.