why I am getting "invalid date:undefined date" in the date and time column of the Table version of my PWS display

  • 2
  • Problem
  • Updated 5 months ago
Any one able to tell me why I am now getting "invalid date:undefined date" in the date and time column of the Table version of my PWS display when using Safari. Previously that column would show the date and time of each entry
Photo of Van Mildert

Van Mildert

  • 8 Posts
  • 3 Reply Likes
  • frustrated

Posted 5 months ago

  • 2
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 645 Posts
  • 92 Reply Likes
Van, can you post a link or email me?  It's impossible to answer this without looking at some actual data.

--Victoria
victoria.gardner@ibm.com
Photo of Eric Fisher

Eric Fisher

  • 2 Posts
  • 0 Reply Likes
I am getting this as well. See link https://www.wunderground.com/dashboar.... It occurs in the table of previous observations
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 643 Posts
  • 91 Reply Likes
I am happy to look into this, but I followed the link, looked through several previous days' data, searched for "invalid", couldn't find it.  Can you send me (or post here) a screen shot, and let me know what browser/platform you're using? 

It sounds like something I would like to get to the bottom of, so please do not hesitate to contact me directly.

--Victoria
victoria.gardner@ibm.com
Photo of Eric Fisher

Eric Fisher

  • 2 Posts
  • 0 Reply Likes
Just tried it in Chrome and the same thing happened
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 643 Posts
  • 91 Reply Likes
URL?  Are you logged in to wunderground.com when it happens?  Are you on a Mac or PC?  What version of Chrome?
(Edited)
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 645 Posts
  • 92 Reply Likes
After getting an email about this, it turns out that it's only in Safari (so far as I know) that this is happening.  When I try both Chrome and Firefox, the table displays as it should.

I have filed a report about it, so it is in the repair queue.

Thanks for the help!

--Victoria
Photo of Van Mildert

Van Mildert

  • 8 Posts
  • 3 Reply Likes
Thanks for the quick response
Photo of Gary

Gary

  • 1 Post
  • 0 Reply Likes
Thanks for getting this into the Fixit queue.  It sorta seems to go away when javascript is disabled for me. The issue occurs with every PWS.   here is a comparison of Safari and Chrome looking at the same PWS with Javascript on.  Safari is on the left.
(Edited)
Photo of Peter Samwell

Peter Samwell

  • 2 Posts
  • 0 Reply Likes
On a related issue - before WU changed things I could download the data from my PWS but this tab seems to have disappeared from the latest desktop version. I have moved to Chrome because of the (invalid date; undefined date) issue but there is no download tab. Any thoughts?
Photo of Victoria Gardner

Victoria Gardner, Official Rep

  • 645 Posts
  • 92 Reply Likes
That download tab is gone for now.  You can copy/paste directly from the table into a spreadsheet.

--Victoria
Photo of Peter Samwell

Peter Samwell

  • 2 Posts
  • 0 Reply Likes
Thank you Victoria. But I download once a year so that is not really practical is it? Why have WU removed such a useful feature?