Working to fix connection timeout problems

  • 1
  • Question
  • Updated 5 years ago
Hello Folks,

We have been having issues with some loadbalancing hardware. I am now trying a new solution. So far, this solution is working much better from the metrics I am looking at.

Can anyone in the community confirm if the API is working better now (Wednesday morning 1:00 AM EDT) vs Tuesday? I am looking for differences in:
+ hung connections (timeouts)
+ slow connections

Many thanks, and many apologies for the equipment issues.

Thank you,
John
Photo of John Celenza

John Celenza, Official Rep

  • 40 Posts
  • 21 Reply Likes

Posted 5 years ago

  • 1
Photo of leecoapps

leecoapps

  • 1 Post
  • 0 Reply Likes
I am experiencing issues with auto ip detection. My query for the current condition using autoip.json is giving me "querynotfound" error with the description "No cities match your search query". Seems like the ip is not auto detected any more.

Regards.

--cp
Photo of heyrolled

heyrolled

  • 1 Post
  • 0 Reply Likes
I can confirm that yesterday morning I had about 20 connection timeouts. I have not seen any timeouts this morning, but I did have 2 connection refused errors.

Thanks!
Photo of oringe

oringe

  • 15 Posts
  • 0 Reply Likes
as of now (1130am EST), i am seeing much more timeouts than ever before. my timeout is 2 seconds. about 1 of every 5 requests are timing out.
Photo of Brendan Dawes

Brendan Dawes

  • 4 Posts
  • 0 Reply Likes
16:55 BST getting timeouts.
Photo of Matt Hale

Matt Hale

  • 1 Post
  • 0 Reply Likes
Same here 12:10 EDT
Photo of mscifo

mscifo

  • 3 Posts
  • 0 Reply Likes
Same here. As of 12:38pm EDT, getting tons of timeouts and "execution expired" messsages. For the requests that don't timeout, it's taking anywhere from 5 secs to 35 secs for a response to be delivered. All requests use to return in sub 1 sec.
Photo of Graeme Burke

Graeme Burke

  • 2 Posts
  • 0 Reply Likes
We are seeing lots of slow responses
When: Wed Aug 14 16:56:43 UTC 2013
Some are fast in the msec range, some take more than a minute.
Photo of mscifo

mscifo

  • 3 Posts
  • 0 Reply Likes
Whatever you did, things are running much faster for us since the last few minutes.
Photo of fruition

fruition

  • 6 Posts
  • 0 Reply Likes
I got the last error 12 minutes ago : "Warning: file_get_contents(http://api.wunderground.com/api/MYKEY...): failed to open stream: HTTP request failed!"
Photo of WebGuruDave

WebGuruDave

  • 14 Posts
  • 0 Reply Likes
Not getting time-out issues with Sat images so far today. Crossing fingers.

Still getting incomplete images, however.